Let ipython3 use the latest python3

Chris Warrick kwpolska at gmail.com
Sat Jan 21 06:49:38 EST 2017


On 21 January 2017 at 12:30, Cecil Westerhof <Cecil at decebal.nl> wrote:
> I built python3.6, but ipython3 is still using the old one (3.4.5).
> How can I make ipython3 use 3.6?

All packages you have installed are tied to a specific Python version.
If you want to use IPython with Python 3.6, you need to install it for
that version (most likely, with pip) and make sure there is an
ipython3 executable in your $PATH pointing at 3.6. You don’t need to
remove IPython for 3.4 (but you can if you want to get rid of it).

-- 
Chris Warrick <https://chriswarrick.com/>
PGP: 5EAAEA16


More information about the Python-list mailing list