The perils of multiple Pythons

Chris Angelico rosuav at gmail.com
Mon Apr 30 17:03:29 EDT 2018


On Tue, May 1, 2018 at 6:59 AM, justin walters
<walters.justin01 at gmail.com> wrote:
> With Python 3.5+, venv is a built in module. If using a venv, default to
> using the binary in the venv.
>
> That's what I do anyways.

Yep. Munroe (the author of XKCD) is clearly using a Mac, though, and
Macs don't ship with Python 3.5+. So there's a bootstrapping problem:
how do you install a newer Python? There are about half a dozen
options.

ChrisA


More information about the Python-list mailing list