pip unable to find an extension of a lib.

Vincent Vande Vyvre vincent.vande.vyvre at telenet.be
Thu Apr 11 03:25:03 EDT 2019


Hi,

Using Python-3.7.2 (compiled with --with-pydebug) in a venv, I've 
encountered this problem:

$ pip install --upgrade pip setuptools wheel
....
Successfully installed setuptools-41.0.0 wheel-0.33.1
-------------------------------

$ pip install pyqt5
   /pip/_vendor/html5lib/_trie/_base.py:3: DeprecationWarning: (skip)
   from collections import Mapping
Collecting pyqt5
   /pip/_vendor/msgpack/fallback.py:222: PendingDeprecationWarning: (skip)
   Using cached 
https://files.pythonhosted.org/packages/98/61/fcd53201a23dd94a1264c29095821fdd55c58b4cd388dc7115e5288866db/PyQt5-5.12.1-5.12.2-cp35.cp36.cp37.cp38-abi3-manylinux1_x86_64.whl
Collecting PyQt5_sip<4.20,>=4.19.14 (from pyqt5)
   Could not find a version that satisfies the requirement 
PyQt5_sip<4.20,>=4.19.14 (from pyqt5) (from versions: )
No matching distribution found for PyQt5_sip<4.20,>=4.19.14 (from pyqt5)
--------------------------------

$ pip search pyqt5
   /pip/_vendor/html5lib/_trie/_base.py:3: DeprecationWarning: (skip)
   from collections import Mapping
pyqt5-tools (5.11.3.1.4)          - Tools to supplement the official 
PyQt5 wheels
PyQt5-stubs (5.12.1.0)            - PEP561 stub files for the PyQt5 
framework
PyQt5-sip (4.19.15)               - Python extension module support for 
PyQt5
PyQt5 (5.12.1)                    - Python bindings for the Qt cross ...
.....

The version of PyQt5-sip (4.19.15) seems OK, no ?

I've already posted on the PyQt ML, but I am the only one with this problem.

Thanks for all advices

Vincent.



More information about the Python-list mailing list