pip unable to find an extension of a lib.

Vincent Vande Vyvre vincent.vande.vyvre at telenet.be
Fri Apr 12 03:05:21 EDT 2019


Le 12/04/19 à 07:40, dieter a écrit :
> Vincent Vande Vyvre <vincent.vande.vyvre at telenet.be> writes:
>> ...
>> Using Python-3.7.2 (compiled with --with-pydebug) in a venv, I've
>> encountered this problem:
>>
>> $ pip install --upgrade pip setuptools wheel
>> ....
>> Successfully installed setuptools-41.0.0 wheel-0.33.1
>> -------------------------------
>> ...
>> $ pip install pyqt5
>> ...
>> Collecting PyQt5_sip<4.20,>=4.19.14 (from pyqt5)
>>    Could not find a version that satisfies the requirement
>> PyQt5_sip<4.20,>=4.19.14 (from pyqt5) (from versions: )
>> No matching distribution found for PyQt5_sip<4.20,>=4.19.14 (from pyqt5)
>> ...
>> $ pip search pyqt5
>> ...
>> PyQt5-sip (4.19.15)               - Python extension module support
> There is a spelling difference: "PyQt5_sip" versus "PyQt5-sip" --
> not sure, however, whether this is important.
>
Yes, I see that but the names returned by pip search are different than 
the names used with pip install

ie: PyQt5 versus pyqt5.


Vincent.



More information about the Python-list mailing list