[Python-mode] python-mode.el 6.0 released

Glenn Linderman v+python at g.nevcal.com
Sat Jul 23 22:02:06 CEST 2011


On 7/23/2011 11:59 AM, Andreas Röhler wrote:
> Am 23.07.2011 20:30, schrieb Glenn Linderman:
>> On 7/23/2011 9:48 AM, Andreas Röhler wrote:
>>> Hi all,
>>>
>>> proudly announcing the release of
>>>
>>> python-mode.el 6.0 at
>>>
>>> http://launchpad.net/python-mode/trunk/6.0/+download/python-mode-6.0.tgz 
>>>
>>
>> Installation instructions?
>
> nothing changed in this respect. python-mode.el should work 
> stand-alone as the previous one.
>
>>
>> Seems like the prior python-mode was just a single file, so pretty
>> straightforward, unpack to d:\somewhere, and then in the emacs rc:
>>
>> (add-to-list 'load-path "d:/somewhere")
>> (autoload 'python-mode "python-mode" "Python Mode." t)
>
> make sure python-mode.el is earlier in path than python.el


Does add-to-list do that?  Or do I need something else?


>
> there are some known hassles, because both modes calling them 
> "python-mode"
>
>
>>
>> The new one has lots of files, not sure what to do with them...
>
>
> have a look into the README

Not explained whether I can keep only python-mode.el or if I need some 
of the other files nearby to make it work.  Could experiment, I 
suppose.  For the moment, I just left them all there.


>
>  anyway,
>> did the same as above, and get the following error:
>>
>
>> Error in menu-bar-update-hook: (void-function region-active-p)
>>
>>
> thanks, will fix this
>
> for the moment please use:
>
> (unless (featurep 'xemacs)
>   (defun region-active-p ()
>     "and mark-active transient-mark-mode
>  (not (eq (region-beginning) (region-end)"
>     (and mark-active transient-mark-mode
>          (not (eq (condition-case nil (region-beginning)(error nil))

Where?

>
>
>  Gnu Emacs 22.1.1 here. I'd upgrade to a newer Emacs, but last time I
>> tried, the "better Unicode support" was actually worse. (Trying to open
>> files with Unicode names, and trying to paste in Unicode text from
>> AutoHotKey.)
>>
>
> Doesn't meet my experience. We are on Emacs23.3 which is the best 
> Emacs ever IMHO.

Glad it is working for you, but it isn't for me.  I offer the following 
description of the problem, but of course it is not a problem with 
python-mode.  But it will serve to explain why my attempts to use 23.1 
some time back and 23.3 today, have failed.

None of Emacs 22.1.1 through 23.3 will open files on Windows containing 
certain characters in their names, partly because the name can't be 
typed properly, but it doesn't even work to drag files with those names 
into emacs.  Probably an issue that is specific to Windows.  Those same 
characters produce some weird error "<packet> is undefined" when certain 
characters are pasted into Emacs by Autohotkey, using at least 
23.1-23.3.  22.1.1 doesn't produce the <packet> error, so is friendlier 
to those characters. Probably another issue that is unique to Windows 
and/or AutoHotKey interaction.  I've tried reporting the <packet> error, 
and eventually someone responded to the email, but I never figured out a 
way to check on the status of a ticket, or figure out when or if it will 
be included in a production version of emacs.  As I use AutoHotKey 
macros to generate non-ASCII symbols using an English keyboard, it is 
critical to my ability to use Unicode characters, and not being able to 
enter them using emacs makes such versions of emacs useless to me.  I 
have never learned Emacs lisp, which is usually not a major problem in 
simply using Emacs, and I can copy/paste "helpful tricks" from various 
web sites for customization.  But this is beyond my capabilities to 
analyze, so I may be stuck on emacs 22.1.1 until someone can fix the 
problem or until I have to give up emacs because 22.1.1 no longer works 
on some future version of Windows.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/python-mode/attachments/20110723/f118ce61/attachment-0001.html>


More information about the Python-mode mailing list