[python-nl] upgrading naar 2.7

Maurits van Rees maurits at vanrees.org
Fri Jul 16 13:44:48 CEST 2010


Op 16-07-10 13:34, Jeroen Ruigrok van der Werven schreef:
> -On [20100716 13:17], Maurits van Rees (maurits at vanrees.org) wrote:
>> Probeer eens easy_intall PIL
>
> Sowieso is PIL niet easy_install vriendelijk.
>
Inderdaad. Als ik nu op mijn Mac in een 2.7 virtualenv bin/easy_install 
PIL doe, gaat dat commando goed, maar 'import PIL'_imaging' werkt wel.

Meestal pak ik een expliciete versie van dist.plone.org (Plone is ook 
mijn dagelijkse bezigheid):

bin/easy_install -f http://dist.plone.org/thirdparty/PIL-1.1.7.tar.gz PIL

of omdat ik de TKinter bindings niet nodig heb:

bin/easy_install -f 
http://dist.plone.org/thirdparty/PILwoTk-1.1.6.4.tar.gz PILwoTk

Met die twee in een 2.7 virtualenv gaat bij mij zowel import PIL als 
import _imaging goed.

werkt niet; 'import
> Tevens zou ik ook Distribute aanbevelen over Setuptools.
+1

Maurits van Rees



More information about the Python-nl mailing list