[python-uk] embedding python ImportError: libpyglib PyExc_ImportError

oly at digitaloctave.com oly at digitaloctave.com
Fri Oct 29 11:49:59 CEST 2010

  BODY { font-family:Arial, Helvetica, sans-serif;font-size:12px;
}This is the result of searching for that library, also i dont get
the error when running python normally only when its embeded, so
something must be different when you embed for the error to only
occur when when running code in the embeded version.
 locate /usr/lib/libpyglib
  I have double checked and i have all the python-dev packages and
all the dev packages for things like gtk and the other libraries i
require and have search for the .h files and they seem to be present
and in place.
 On Fri 29/10/10  8:39 AM , Jamie Kirkpatrick
jkp at kirkconsulting.co.uk sent:
 Well, do you have that library on your system?  The problem is that
you are loading a Python module that uses a C extension module under
the hood so your python runtime is looking to load in that library as
you import that module but its not finding it. 
 How have you "installed" the gtk module so your embedded Python can
see it?  I've never embedded Python in a C application before but
I'll do what I can to help you :)
  BTW: A great site for quick answers to questions like this (if you
don't already know it) is stackoverflow.com [1]
  On 28 October 2010 22:46, Oliver Marks  wrote:
  Hi i am a new member on this list and thought if some people may be
 to enlighten me to the error below ?
 I am running 64 bit ubuntu 10.10 in case there are know issues with
 setup, basically i am embedding python inside a c application i
 to get this to work i can call functions from the original c program
 the scripts run until i import gtk in the python script this causes
 error below.
 I am using the waf build system to build the c program, my knowledge
 c is limited i am more a python programmer which is why i am
 the embed python so i can write my plugins in python.
 I get the feeling the error is todo with linking but i dont get why
 can import gtk normally in python but not when its embeded ?
 Any help or pointers would be appreciated, that might help me get
 solved or better understand what is wrong.
 Traceback (most recent call last):
   File "/usr/local/share/geany/plugins/gpykickstart.py", line 4, in
     import glib
   File "/usr/lib/pymodules/python2.6/gtk-2.0/glib/__init__.py", line
     from glib._glib import *
 ImportError: /usr/lib/libpyglib-2.0-python2.6.so.0: undefined
 Failed to load the "gpykickstart" module from the
 "/usr/local/share/geany/plugins" directory.
 python-uk mailing list
 python-uk at python.org [3]
 http://mail.python.org/mailman/listinfo/python-uk [4]

[1] http://stackoverflow.com
[2] mailto:oly at digitaloctave.com
[3] mailto:python-uk at python.org
[4] http://mail.python.org/mailman/listinfo/python-uk
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/python-uk/attachments/20101029/5345f03b/attachment.html>

More information about the python-uk mailing list