[python-uk] Packaging advice for ujson / rpm / RHEL5

Nicholas H.Tollervey ntoll at ntoll.org
Tue Jan 29 07:44:46 CET 2013


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Wow, what a great set of answers. Thanks guys..!

N.

On 28/01/13 09:01, Nicholas H.Tollervey wrote:
> Hi,
> 
> I need to build an RPM of ujson for RHEL5 targeting Python2.6.
> This will be deployed on "front end" boxes that do not have a
> compiler installed (hence I can't just pip install the damn
> thing).
> 
> All the RHEL5 machines have Python 2.4, 2.5 and 2.6 installed with
> the default being 2.4 (what you get from /usr/bin/python).
> 
> If I run setup in the root of the ujson project like this:
> 
> $ python2.6 setup.py bdist_rpm
> 
> I notice from the output from GCC that the script has the -fPIC
> flag reference /usr/include/python2.4
> 
> :-(
> 
> Obviously, compilation is being done against the wrong version of
> Python.
> 
> Anyone know how to pass in or force the version to Python 2.6?
> 
> Many thanks,
> 
> Nicholas. _______________________________________________ python-uk
> mailing list python-uk at python.org 
> http://mail.python.org/mailman/listinfo/python-uk
> 

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with undefined - http://www.enigmail.net/

iQEcBAEBAgAGBQJRB2/bAAoJEP0qBPaYQbb67iYH/23tTxE4t+DmwXByvhrWJoc0
U0qS7vPvErHUSE1tn4byGE/oZ/l8FbT4Ov78qpG9yVPjdQ6L3qk2h1dd2E4t6y/L
QrTEQ5ebFGenVO5FUv0doMf3k2egunUWCdAcOMf5wdRSkwN3l/6xyewCxIX6p2Ju
kmbceQQPbGjl9Pxy8KfLUSwX7TYHbqEx9MjrmJNTAzwnlye6i6erP3gFvRN7bvZl
KPEtIkkt6xA2qiEmNyP3K3ifkfSIsNFP17hzhkTpO9GK98CDOSNTvbqIMnuJ4QBR
kG5UMAi3UkuK5wK0cMbGI+VHsscQte1edPMofnAQE7oEBn/4QooB7GMf5383owo=
=XBjC
-----END PGP SIGNATURE-----


More information about the python-uk mailing list