[python-uk] PyGame Zero: I tried to install but I failed :/

a.grandi at gmail.com a.grandi at gmail.com
Sat Jun 6 18:01:38 CEST 2015


Hi,

after the amazing evening at last Python Dojo, I decided to try to use
PyGame Zero by myself, but I wasn't able to install it :/

I tried on a Mac (OSX Yosemite). I first installed Python 3 using brew
(I normally use Python 2.7) and I created a venv with this command:

mkvirtualenv -p /usr/local/bin/python3.4 pgz
Running virtualenv with interpreter /usr/local/bin/python3.4
Using base prefix
'/usr/local/Cellar/python3/3.4.3/Frameworks/Python.framework/Versions/3.4'
New python executable in pgz/bin/python3.4
Also creating executable in pgz/bin/python
Installing setuptools, pip, wheel...done.
(pgz)➜  ~

until here... everything ok.

When I try to install pygame zero from pip I get this error:

(pgz)➜  ~  pip3 install pgzero
DEPRECATION: --download-cache has been deprecated and will be removed
in the future. Pip now automatically uses and configures its cache.
Collecting pgzero
  Downloading pgzero-1.0.2.tar.gz (326kB)
    100% |████████████████████████████████| 327kB 955kB/s
Collecting pygame>=1.9 (from pgzero)
  Could not find a version that satisfies the requirement pygame>=1.9
(from pgzero) (from versions: )
  Some externally hosted files were ignored as access to them may be
unreliable (use --allow-external pygame to allow).
No matching distribution found for pygame>=1.9 (from pgzero)

even using pip instead of pip3 doesn't help.

I'm pretty sure I'm doing something wrong but I'm not able to figure
out what. Has anyone any idea about what's wrong with my setup?

Thank you so much for your help!

Cheers.

-- 
Andrea Grandi - Software Engineer
Website: http://www.andreagrandi.it
Twitter: https://twitter.com/andreagrandi
GitHub: https://github.com/andreagrandi
PGP: 7238 74F6 886D 5994 323F 1781 8CFB 47AD C384 F0CC


More information about the python-uk mailing list