[python-win32] Library not Registered Error while running

siddhartha veedaluru siddhartha.veedaluru at gmail.com
Mon Mar 17 07:37:55 CET 2008

Date: Fri, 14 Mar 2008 12:59:26 +0000
From: Tim Golden <mail at timgolden.me.uk>
Subject: Re: [python-win32] Library not Registered Error while running
       WMI example script
Cc: python-win32 at python.org
Message-ID: <47DA76AE.2040809 at timgolden.me.uk>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

siddhartha veedaluru wrote:
> I have installed win32 extensions on my windows 2003 server
> i'm using python 2.5.1.
> downloaded the wmi module 1.3.2 to my machine
> used
> "python setup.py install"
> to install the module
> i tried run an example mentioned in the web page. it gave the following
> error.
> File "C:\Python25\Lib\site-packages\wmi.py", line 157, in __init__
> comobj._oleobj_.GetTypeInfo().GetContainingTypeLib()[0].GetTypeComp()
> pywintypes.com_error: (-2147319779, 'Library not registered.', None, None)
> Script terminated.

Just to test, could you run this code to see if it produces
the same result? (This is basically what the wmi module
does behind the scenes).

import win32com.client
win32com.client.GetObject ("winmgmts:")

Hi ,

I have tried the snipped
The script just terminted with any output or error.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.python.org/pipermail/python-win32/attachments/20080317/cf718808/attachment.htm 

More information about the python-win32 mailing list