[PythonCE] No clue what's going on

Anne Wangnick anne.wangnick at t-online.de
Sat Dec 4 23:35:39 CET 2004

Dear all,

I'm lost. I've downloaded and installed Python-2.3.4-arm-PPC2003.zip and
pythonce-Tkinter-Files.zip on my PDA (Pocket Loox 720, Windows Mobile 2003
SE, VGA screen), and have successfully used this installation to port a
resonably-sized application to the PDA. I had some issues in the beginning
where Python would fail loading dll's or give memory errors, but finally
everything worked reasonably well. I've even succeeded adding the
HI_RES_AWARE resource to the python.exe, thus giving Tkinter access to the
full VGA resolution of the devive.

However, lately I did some rearrangement of software and files on the PDA,
and since then the Python interpreter just silently vanishes when starting
the application.

I then tried to build the Python interpreter myself, namely the debug
version, using EVC++ (version 4.00.1505.0, product ID

The executable behaves different from the downloadable binary, though.
Whenever I try to double-click the most simplest Python file (with the
registry set up properly, Shell.Open.Command set to
"\Programme\Python.evc\Lib\Python.exe" "%1"), I get a window titled "Python
Error", containing:
	Traceback (innermost last):
	exceptions.ImportError: No module named \My Documents\turtle.py

The downloaded Python works fine with this file ...

Any ideas?


More information about the PythonCE mailing list