[PythonCE] wxPython for Python 2.5?

Matt S. sleepingbull at gmail.com
Sat Apr 19 02:16:10 CEST 2008

Hi everyone,

Hope you're well.  This past week I tried building wxPyCE for Python 2.5.
The directions for building wx for 2.4 are at,


I succeeded at building for 2.4 but not for 2.5.  After catching up on
PythonCE emails over the past year it seems that wxPyCE has lost its mojo.
Ingmar Steen, who did a really nice job porting for 2.4 and documenting it,
seems to have lost interest.  Alexandre mentioned he would compile... but
it's not clear that he has done so.  I don't know the least about compiling,
SWIG, etc... and I don't really have time to master these tasks.  Has anyone
ported wxPythonCE to Python2.5?  If someone wants to give me guidance on how
to get wx running for 2.5 I'd be happy to try to compile it/document how to
do it/etc.

Why am I interested in wxPyCE?  I've been able to make a pretty cool wx app
for the PPC2003.  Two things motivated me to update my app to 2.5.  First, I
wanted to pickle a class object (that holds all my data and is pretty
complicated).  This works fine in 2.4 on the PC but not on the PocketPC.  I
was hoping updating to 2.5 would solve my problem.  Unfortunately, just
trying out 2.5 has snowballed into a major effort.  In going to 2.5 I was
also looking forward to ctypes being included in the distro.  An additional
motivation was just to keep my app current.  Well, any help is greatly

Here's a little info on my failed hack attempt:
When I tried to compile for 2.5 I had to rename /python/lib/python25.lib to
python24.lib.  Somewhere in the wxpyce.vcw project, when trying to compile
_core_files, etc. there is a dependency on the lib being name python24.lib.
So I tried to hack this by renaming 25 to 24.  Things then compile alright.
But when I start up PythonCE 2.5 and import wx I get _core_ errors.  It
seems that wx is looking for _core_ but there is only _core.  I just tried
replacing "import _core_" to "import _core as _core_" but then I get a
_core_.wxPySetDictionary error.  I'm guessing this method doesn't exist in
the 2.4 wx source.  Clearly my hacking skills have hit a ceiling.

Best regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.python.org/pipermail/pythonce/attachments/20080418/c02f7148/attachment.htm 

More information about the PythonCE mailing list