[Python.NET] Using numpy/matplotlib - DLL Load Failed

ElMariachi lo.maximo73 at gmail.com
Wed Apr 20 22:46:15 CEST 2011

I have tried, as you mentioned, importing multiarray first. It is a module
declared in numpy.core (the filename is "multiarray.pyd") though I keep
getting the same error. Any idea what else I might try? 

>>> from numpy.core import multiarray
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "c:\python27\lib\site-packages\numpy\__init__.py", line 142, in
    import add_newdocs
  File "c:\python27\lib\site-packages\numpy\add_newdocs.py", line 9, in

    from numpy.lib import add_newdoc
  File "c:\python27\lib\site-packages\numpy\lib\__init__.py", line 4, in
    from type_check import *
  File "c:\python27\lib\site-packages\numpy\lib\type_check.py", line 8, in
    import numpy.core.numeric as _nx
  File "c:\python27\lib\site-packages\numpy\core\__init__.py", line 5, in
    import multiarray
ImportError: DLL load failed: The specified module could not be found.

Tribble, Brett wrote:
> Import multiarray first as well. Numpy is doing an import in the __init__
> according to what I see here, unless I'm wrong, which is also likely.
> Lather, rinse, repeat for any additional modules that fail to load.
> This bug has plagued my pythondotnet usage since day 1...

View this message in context: http://old.nabble.com/Using-numpy-matplotlib---DLL-Load-Failed-tp31397569p31443742.html
Sent from the Python - pythondotnet mailing list archive at Nabble.com.

More information about the PythonDotNet mailing list