[Pythonmac-SIG] Darwin build of Python-2.0c1

Steven D. Majewski sdm7g@virginia.edu
Tue, 10 Oct 2000 16:07:09 -0400 (EDT)


On Tue, 10 Oct 2000, Tony Lownds wrote:

> >( *DON'T* use --with-next-framework ! just edit Modules/Setup and
> >    run make again. )
> 
> I know that you can't get a working install if you build with 
> --with-next-framework - did you experience other issues?

No -- it went remarkably smoothly. With your initial patches, I 
still had to pass some environment variables to get thru the linking.
I really did a 
	configure --with-dyld --with-suffix=.x
	make 
right out of the box -- 
then copied my old editied Modules/Setup file and it built with
dynamic modules. 


 I was getting very frustrated trying to figure out how to 'fix' 
your fixes on the previous release: some things that were patched 
didn't seem to take (like the -lcc_dynamic for example ) - maybe they 
were patched in the wrong place. However, despite all my efforts
to start clean, almost every make seemed to work differently. 
 Reflecting on this, I realize that make and configure are the ultimate
context dependent tools -- obviously by design -- that's what they are
there for -- but it takes only a slight change in the environment to 
make a problem irreproducible! 

 I hope the ease of installation means that somebody who really 
understands make and configure took a hack at cleaning it up before
the release. ( I'm assuming that if I do a 'make clean' and configure
and build again, I'll actually get back to the same place this time! ) 


Remaing gotcha's:
> >
> >[3] test/test_fcntl.py will still fail unless you add "Darwin1.2"
> >among the BSD's:
> 
> I think you should post that patch to python.sourceforge.net!
> 

I tried, but right after I downloaded the new distribution, it
seemed temporarily unreachable. ( Maybe it was overwhelmed with
a million new python downloads this morning! ;-) 

I'll give it another try. 


> also:
> 
> [4] make install should be able to rename python.x to python
> This is advertised in configure --help as "--program-transform-name" but it 
> isn't supported in the Makefile

That would be nice -- I've been manually renaming it so I don't have
to remember to add the .x ! 
 


Now : Has anyone ported Tk to Darwin yet ? 

Now that shared libs are working, maybe we can set up a public 
to-do list and try to get some parallel processing done in porting
and doing new modules. 

Do you know anything about the last status of the objc bindings ?
I downloaded a copy: ( I think it claimed to be 0.55 ) 
the make file was set up for linking with gnustep.
I tried to manually compile a couple of files, and ran into some
errors right away. 


Having no other experience yet with NextStep/OpenStep/GnuStep/Cocoa
under any of it's names, I'm probably going to leave that aside for
now and see if I can port either some Mac/Carbon modules or some
X11 based modules first. 


---|  Steven D. Majewski   (804-982-0831)  <sdm7g@Virginia.EDU>  |---
---|  Department of Molecular Physiology and Biological Physics  |---
---|  University of Virginia             Health Sciences Center  |---
---|  P.O. Box 10011            Charlottesville, VA  22906-0011  |---
		"All operating systems want to be unix, 
		 All programming languages want to be lisp."