[Pythonmac-SIG] Python and Oracle

Barron Snyder barronsnyder@mac.com
Sun, 5 May 2002 01:30:04 -0500

Well, it's working now!

I did 2 things, I updated my Fink files including getting the latest 
Python that Fink has and I tried the suggestion from Stuart (thanks 
Updating my Fink files seemed to rid me of the warning messages 
(warning: function declaration isn't a prototype) but I was still 
getting the error:

	/usr/bin/ld: can't use -s with -bundle (file must contain at least 
global symbols, for maximum stripping use -x)
	error: command 'cc' failed with exit status 1

So, I tried remarking out the -s line in setup.py:
	extra_link_args = ["-s"],

And it installed fine!

I setup my tnsnames.ora file, wrote a quick test script, and retrieved 
some Oracle data!

Thanks to everyone for their suggestions!

I'm pretty familiar with setting up the Oracle client on windows and 
unfortunately, that's the platform I have to code for (I write in-house 
applications for a large company.). But just because my users are all on 
windows, I don't have to be <g>. I'm very interested in cross-platform 
development and have been very successful with Java in that regard. Most 
of the work I do is Java (obviously not c/c++ <g>) and I now write all 
my code in OS X and then move it over to windows without having to 
change a single line. JDBC is great in that regard. Lately, however, 
I've gotten very excited about Python and want that same portability 
with Python that I have with Java. Getting this Python <-> Oracle 
connectivity working has been a key step!

Thanks again everyone!


On Sunday, May 5, 2002, at 12:41 AM, Stuart Bishop wrote:

> On Saturday, May 4, 2002, at 11:59  PM, Barron Snyder wrote:
>> I'm not very familiar with c/c++ and compiling anything for OS X (but 
>> trying to learn).
>> Do I need to worry about the warnings (warning: function declaration 
>> isn't a prototype)?
>> Can anyone tell me what the error "can't use -s with -bundle" means?
> It means that during the linking stage, the build script is trying to
> invoke the linker with two incompatible options. At this point, I'd
> try grepping for '-s' in the makefiles and removing them to see if this
> is your problem, or just the tip of an iceburg. Removing -s should not
> have any ill effects besides bloating the size of the generated 
> binaries.
> If you give up (building just about anything using Oracle libraries is
> painful even on their best supported systems), you may find using
> jython, the zxJDBC DB-API implementation and the thin JDBC drivers
> from Oracle may be the best way to proceed, and would also be the
> simplest if you need to distribute and license the application you
> are writing. I would also guess it to be the most stable if the
> Mac drivers are that new...
> --
> Stuart Bishop <zen@shangri-la.dropbear.id.au>
> http://shangri-la.dropbear.id.au/