[Pythonmac-SIG] Problem with a py2app bundle

Bob Ippolito bob at redivi.com
Sun May 8 19:41:17 CEST 2005

On May 8, 2005, at 3:45 AM, Quentin DECAVEL wrote:

> Okay I've installed py2app and pygame, plus pyObjC, MacPython 2.4  
> and the some
> packages versions that were available on the site (the app  
> complained that it
> could not find the PyObjC module), and launched a new bundle  
> creation, but
> this time the application crashed much sooner, and the only trace  
> that I
> received was no the Console:

pygame requires PyObjC on Mac OS X

> 2005-05-08 09:35:00.710 Greenhouse[1838] Greenhouse Error
> 2005-05-08 09:35:00.711 Greenhouse[1838] An unexpected error has  
> occurred
> during execution of the main script
> ImportError: No module named rotor
> See the Console for a detailed traceback.

rotor was an insecure encryption module that was deprecated in Python  
2.3 (maybe earlier) and removed in Python 2.4.  You'll have to figure  
out where/why your application is using it and make sure it doesn't,  
or build with python 2.3.


More information about the Pythonmac-SIG mailing list