[Pythonmac-SIG] readline support in ActivePython 2.4.2?

Dave davbrow at gmail.com
Wed Nov 30 08:01:06 CET 2005

[Trent Mick <trentm at ActiveState.com> said]

>[Dave wrote]
>> I installed the ActivePython 2.4.2 binary on a clean 10.4 system.  I
>> also installed ipython 0.6.15.  ipython complains there is no readline
>> support.  I did find a readline.so file in
>> /Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/lib-dynload/
>> and ipython seems to be using the 2.4.2 python version.
>> How can I get readline to work, especially in ipython?  Is there an
>> obvious fix or should I perhaps uninstall the ActivePython version and
>> use the 2.4.1 installer and related patches at
>> http://undefined.org/python/
>Currently the readline module is not in ActivePython builds. Mainly this
>is due to licensing issues: readline is GPL, ActivePython is free as in
>beer.  I *do* want to make it a simple separate download to be able to
>plop in readline support, but haven't yet had the chance.

>You could either build the readline module to any Python 2.4 and plop
>that in. Dropping in the readline.so from the Mac Python build should
>work to.

Thanks for the info Trent.  When using ipython it's very much
necessary to have readline support.  In my case I really only use the
arrow keys and tab but I suspect ipython would break if the full
module was not provided.  I was desperate and, lacking clues or
documentation (even Google failed me), I uninstalled the ActiveState
version and used the 2.4.1 installer.  Frankly I really appreciated
the uninstaller script and clear instructions that were part of the
ActiveState distribution!  Very few packages I've seen are so
carefull.  I'll probably try it again for a future update.  Also, I
and I'm sure many others would appreciate a separate download or a few
README comments on how to get readline installed if it's needed.

For future reference and for the benefit of other readers, I'm still
unclear on how to actually get readline working.  I had tried to build
readline (twice, once standalone using make and once using
darwinports) and it seemed to work but I don't know where to place it.
 This is for OS X but, in general for unix systems how can you tell
where a library is supposed to be located?  Is there any standard or
convention?  I tried a few places including /lib-dynload but ipython
still complained and I got those telltale '[]^' codes when I tried to
use arrow keys.

I'm not done with installs.  I tried to install matplotlib from source
to get a current version.  That went equally as well (i.e., bad),
possibly for similar reasons, but that's another story.  Meanwhile the
old machine with rock-solid 10.3.9 and all the python 2.3 toys is
quietly enjoying the show.

-- Dave

More information about the Pythonmac-SIG mailing list