[Pythonmac-SIG] framework on Intel

Kevin Walzer sw at wordtech-software.com
Tue Feb 28 10:06:35 CET 2006

Hash: SHA1

Ronald Oussoren wrote:
> On 26-feb-2006, at 2:08, Charles Hartman wrote:
>> My interest in the universal build of 2.4.2 has gotten less abstract,
>> because I just (just) got my Intel iMac.
>> I guess I *might* figure out how to build Python 2.4 for myself,
>> though it would be guaranteed to produce a lot of messages to list
>> asking dumb questions . . .
> You could use the tree at http://svn.pythonmac.org/python24/python24- 
> fat,
> check out using subversion and then build using:
> $ configure --enable-framework --enable-universal-sdk
> $ make
> $ sudo make frameworkinstall
> Please let us know of the results. The installer for the universal  
> binary
> is very close to being finished, I'm currently working on creating an
> .mpkg instead of a single package. When that is finished we should have
> a working installer of a universal python 2.4 build.
>> So I'm wondering if the binary installer is still looking very close?
>> Or would it be smarter for me to download the current 2.4.1 PPC
>> version and run under Rosetta for a while? (It will work, right?)
> Running the current version using Rosetta will work as well.
> Ronald
> _______________________________________________
> Pythonmac-SIG maillist  -  Pythonmac-SIG at python.org
> http://mail.python.org/mailman/listinfo/pythonmac-sig
I tried to build again, and failed again. Here is where the error occurred:

ld: warning can't open dynamic library:
- -all_load/usr/lib/system/libmathCommon.A.dylib referenced from:
(checking for undefined symbols may be affected) (No such file or
directory, errno = 2)

This looks weird. Possibly a problem on my system only?
OS X 10.4.5, XCode 2.2.

- --
Kevin Walzer
iReveal: File Search Tool
Version: GnuPG v1.4.1 (Darwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the Pythonmac-SIG mailing list