[Pythonmac-SIG] Newbie troubles with MacPython 2.4.1 / Tiger 10.4.3

Mark Asbach mark.asbach at post.rwth-aachen.de
Tue Jan 3 22:27:33 CET 2006

Hi everybody,

I know this should / could be a FAQ, but unfortunately I didn't find  
anything appropriate on the MacPython pages or the Python Wiki.  
Here's my problem:

I started with a iMac G5 with all Apple updates installed. Then I  
installed MacPython-OSX-2.4.1-1, directly after that I installed the  
TigerPython24Fix-r2. Then I started up the PackageManager and tried  
to get those modules that I need. I successfully installed PIL-1.1.5- 
binary, but when I tried to install numarray-1.2.3-binary, the  
install failed. Now there's an incomplete numarray on my disk that  
fails to import into python2.4 with the error	"no module named  

When I enable "Show Hidden" in PackageManager, the pseudo packages  
"WriteableBin-hidden" and "WriteableInclude-hidden" appear not to be  
installed. It's also interesting, that when I disable "For Current  
User Only", I get a warning that says "Install directory '/Library/ 
is not writeable or not readable". That's correct:

	iMac:~ asbach$ ll /Library/Frameworks/Python.framework/Versions/2.4/ 
	total 8
	-rw-r--r--   1 root  admin  119 Mar 31  2005 README

Hm. Did I overlook something? What should I do to get numarray  
installed? chown the installed version of Python 2.4 so that I own  
them (instead of root), chmod g+w all modules, or do something more  

Thanks in advance,


More information about the Pythonmac-SIG mailing list