[Pythonmac-SIG] Universal binary build of py2app application won't run on 10.3.9

Ronald Oussoren ronaldoussoren at mac.com
Sat Jul 1 18:52:22 CEST 2006

On Jun 30, 2006, at 11:33 PM, William Kyngesburye wrote:

> On Jun 30, 2006, at 3:50 PM, Christopher Barker wrote:
>> I'm guessing that this may not be the ONLY lib that has this
>> problem --
>> it's just the the one that's been discovered. Also, it seems possible
>> that a user might have a similar problem with a lib that isn't
>> Apple's.
> Here's a list of Panther-Tiger incompatibilities I came up with when
> working out Panther-compatible Tiger builds (not quite exhaustive,
> mainly stuff that directly affected what I was doing):

[... lis snipped ...]

The more I work on supporting 10.3.9 and 10.4 the more I believe that  
the binary installer shouldn't link to system versions of libraries  
that aren't in a part of the OS where Apple is serious about  

That is the easiest way  to achieve compatibility with older OS  
releases without extensive testing.

BTW. I don't know what I'll do once 10.5 is out, I might stop working  
on 10.3.9 support.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 2157 bytes
Desc: not available
Url : http://mail.python.org/pipermail/pythonmac-sig/attachments/20060701/cde3bb10/attachment-0001.bin 

More information about the Pythonmac-SIG mailing list