[Pythonmac-SIG] Universal wxPython app fails when run on second (PPC) machine

Erik Westra ewestra at gmail.com
Mon Jul 3 11:08:02 CEST 2006

Hello, pythonmac folks.

Thanks to all the hard work you guys have been doing getting Python  
to run on Intel, I have a wxPython application which runs beatifully  
on my MacBook Pro.  I'm using the Framework build of Python 2.4.3  
under OSX 10.4.6, with the "pre-release" universal wxPython version  This works perfectly on the Intel machine, but I now  
have to create a standalone version of my system which also runs on  
PPC-based Macs.

I downloaded and installed Bob Ippolito's py2app, version 0.2.5 from  
http://pythonmac.org/packages/py24-fat.  To my pleasant surprise it  
worked first time, successfully building a standalone version of the  
application which runs on the Intel machine just fine.  But when I  
try to copy the app and run it on a second (PPC-based) machine, the  
application crashes with the following error message:

> Traceback (most recent call last):
>   File "/Users/erik/Desktop/Risk Reporter/Risk Reporter.app/ 
> Contents/Resources/main.py", line 57, in main
>   File "Framework.pyc", line 264, in run
>   File "main.py", line 82, in startup
>   File "main.py", line 21, in __init__
>   File "library/utilities/wxUtils.py", line 388, in __init__
>   File "Framework.pyc", line 122, in get
>   File "Framework.pyc", line 350, in _getPythonModule
>   File "library/Workbench/Workbench.py", line 30, in ?
>   File "Framework.pyc", line 134, in get
>   File "Framework.pyc", line 350, in _getPythonModule
>   File "library/Workbench/PythonShell.py", line 11, in ?
>   File "wx/py/__init__.pyc", line 8, in ?
>   File "wx/py/crust.pyc", line 15, in ?
>   File "wx/py/editwindow.pyc", line 8, in ?
>   File "wx/stc.pyc", line 10, in ?
>   File "wx/_stc.pyc", line 18, in ?
>   File "wx/_stc.pyc", line 11, in __load
> ImportError: Failure linking new module: /Users/erik/Desktop/Risk  
> Reporter/Risk Reporter.app/Contents/Resources/Python/lib-dynload/wx/ 
> _stc.so: Library not loaded: /usr/local/lib/wxPython- 
> ansi-
>   Referenced from: /Users/erik/Desktop/Risk Reporter/Risk  
> Reporter.app/Contents/MacOS/../Frameworks/libwx_macd_stc-2.6.0.dylib
>   Reason: image not found

I'm not sure if this is because the application is running under PPC,  
or if the application is trying to load /usr/local/lib/wxPython- 
ansi-, which just happens to be  
installed on the MacBook Pro but not on the PPC machine.

Any suggestions for how to get this going?  Do I need a later version  
of py2app, perhaps?  Or can I add something to my setup.py script to  
force this library to be included in the bundled application?


  - Erik.

More information about the Pythonmac-SIG mailing list