[Pythonmac-SIG] Building python 2.4.3 on OSX 10.3.9

Michael Glassford glassfordm at hotmail.com
Fri Jul 7 20:20:30 CEST 2006

Bob Ippolito wrote:
> On Jul 7, 2006, at 10:44 AM, Michael Glassford wrote:
>> When I try to build Python 2.4.3 on OSX 10.3.9, I get the following  
>> error:
>> """
>> gcc -c -fno-strict-aliasing -Wno-long-double -no-cpp-precomp
>> -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -I.
>> -I./Include  -DPy_BUILD_CORE
>> -DPYTHONPATH='":plat-darwin:plat-mac:plat-mac/lib- 
>> scriptpackages:lib-tk"' \
>>          -DPREFIX='"/usr/local"' \
>>          -DEXEC_PREFIX='"/usr/local"' \
>>          -DVERSION='"2.4"' \
>>          -DVPATH='""' \
>>          -o Modules/getpath.o ./Modules/getpath.c
>> Modules/getpath.c: In function `calculate_path':
>> Modules/getpath.c:385: `uint32_t' undeclared (first use in this  
>> function)
>> Modules/getpath.c:385: (Each undeclared identifier is reported only  
>> once
>> Modules/getpath.c:385: for each function it appears in.)
>> Modules/getpath.c:385: parse error before "nsexeclength"
>> Modules/getpath.c:409: `nsexeclength' undeclared (first use in this
>> function)
>> make: *** [Modules/getpath.o] Error 1
>> """
>> Does this mean that the configure process didn't work properly? That
>> something's wrong with lib-tk? Something else?
>> If it might be a lib-tk problem, is there a way to remove it from the
>> installation, since I don't need it?
> Sounds like you might not have the latest version of Xcode installed.

As far as I can tell, XCode isn't installed at all. I ran the XCode 2.3 
installer, but it says "You can only install this software on MacOS 
10.4". I couldn't find installers for any earlier versions of XCode.

> Why are you building it yourself anyway?

I already ran the installer for the universal binary version of 2.4.3. 
When I run that version of Python and "import bz2", I get the error:

 >>> import bz2
Traceback (most recent call last):
   File "<stdin>", line 1, in ?
ImportError: Failure linking new module: /usr/lib/libbz2.1.0.dylib: 
can't open library: /usr/lib/libbz2.1.0.dylib  (No such file or 
directory, errno = 2)

This is the same error I reported on 6/28/06 in a different context: a 
py2app application built on OSX 10.4 gives me this error when run on OSX 
10.3.9. I hadn't realized at the time that I would get the same error 
when I ran Python 2.4.3 on 10.3.9. I was hoping that if I built the 
Python myself, it would link correctly to the version of libbz2 that is 
on OSX 10.3.9.

> -bob
> _______________________________________________
> Pythonmac-SIG maillist  -  Pythonmac-SIG at python.org
> http://mail.python.org/mailman/listinfo/pythonmac-sig

More information about the Pythonmac-SIG mailing list