[Pythonmac-SIG] Errors in Numpy running matplotlib

Charlie Moad cwmoad at gmail.com
Sat Jul 15 03:13:51 CEST 2006

On 7/14/06, Christopher Barker <Chris.Barker at noaa.gov> wrote:
> James Kebinger wrote:
> > Thanks for responding. Every library I'm using came prebuild from
> > http://www.pythonmac.or/packages/py24-fat/index.html. I don't know who
> > built them or when.
> Nor do I, but I'm having the same problem as you with them, on a PC Mac.
> So I'm working on re-building it.
> > It would indeed be nice for the repository to host a set of
> > libraries that work together.
> Yes, we need to be careful about that. maybe .eggs would work better, as
> I think they can check dependencies, but mpkgs are so easy to build and
> install.
> > I'd be happy to lend a hand in this if there
> > are directions for building the universal binaries and installers.
> It's quite easy, at least when everything "just works".
> 1) Make sure you have the universal build Python
> 2) get Py2App (from that same site)
> 3) % bdist_mpkg  ( in the directory where the setup.py for your package
> lives ).
> Then look in the "dist" directory for the mpkg.
> Matplotlib is trickier, as it requires all sorts of dependencies, both
> Python packages and not. And as you've seen, the versions have to match.
> I'm working on it now. I have a written up what I've done in the past,
> it's in the MPL package you can find on pythonmac.org for OS-X 10.9 and
> Python 2.3.5

I built the matplotlib on the listing and it requires numpy-0.9.6.  I
have ran into issues in the past with the multiarray module
conflicting between Numeric and numpy.  As I said in the other mpl
thread, let me know if you need any help.

- Charlie

More information about the Pythonmac-SIG mailing list