[Pythonmac-SIG] py2app with libraries compiled with intel compilers, intel libguide.dylib not included

Dan White dan at chalkie.org.uk
Wed Jun 14 17:01:04 CEST 2006


Hi Python Mac folks,

  I am using intel compilers to make VTK dylibs,
then py2app 0.2 maint  svn version to make a .app bundle

When I run the .app that i am making it complains about not being  
able to find one of the intel compiler .dylib s
libguide.dylib
which is found at
/opt/intel/cc/9.1.024/lib/libguide.dylib

how do I get py2app to include this dylib correctly so the vtk libs  
can see it as they do when I run my app from the command line?

Adding libguide.dylib to the .app/Contents/Frameworks/ dir does not  
solve the problem,
does py2app need to know about /opt/intel/cc/9.1.024/lib ?

any clues?

cheers

Dan



Dr. Daniel James White BSc. (Hons.) PhD
Bioimaging Coordinator
Nanoscience Centre and Department of Biological and Environmental  
Sciences
Division of Molecular Recognition
Ambiotica C242
PO Box 35
University of Jyväskylä
Jyväskylä
FIN 40014
Finland

+358 14 260 4183 (work)
+358 468102840 (mobile)
http://www.bioimagexd.org
http://www.chalkie.org.uk
dan at chalkie.org.uk
white at cc.jyu.fi




More information about the Pythonmac-SIG mailing list