[Pythonmac-SIG] .so import bug python 2.3 vs 2.4 (++?)

David Worrall vip at avatar.com.au
Fri Apr 13 09:12:42 CEST 2007


Hello all,
OSX 2.4.9:
A (largish) Xcode project compiled to a .so with the /System/Library  
python framework.
The .so is produced and imports into python (2.3.4)

When the whole process is repeated, replacing python 2.3.4 with 2.4.3
I get an
>> ImportError: Inappropriate file type for dynamic loading

can anyone shed any light on this for me please?
(or just tell me what's gotta change :-)

David
_________________________________________________
experimental polymedia:	www.avatar.com.au
Sonic Communications Research Group,
University of Canberra:	 www.canberra.edu.au/vc-forum/scrg





More information about the Pythonmac-SIG mailing list