[Pythonmac-SIG] Trouble with wxPython

Kent Johnson kent37 at tds.net
Sun Mar 18 18:15:27 CET 2007

I am having trouble getting wxPython apps to work. I have a MacBook Pro
with OS X 10.4.8. I have Python 2.4.4 and Python 2.5 installed, both
using the framework installs from pythonmac.org.

I have several wx apps I would like to use: SPE and Firedrop, to
start. I haven't been able to get them working correctly. I have
tried with Python 2.4 and 2.5 and wxPython 2.6 and 2.8
(again using the installers from pythonmac.org).

The best results I have had are with Python 2.5 and wxPython 
With this setup,

- SPE (using SPE from svn trunk) launches to show a menu bar. No windows 
open. When I select from
the menu nothing happens. To quit I have to force quit from the dock 
(File/Quit does nothing)

- Firedrop2 mostly works. Some of the font sizes are very small and it 
crashes with a bus error when I try to use some of the dialogs. For 
example selecting Options / Set font size bus errors in 

- The wx demos are strange. If I run them individually they work fine. 
If I run the demo app, some of the demos work but many of them show 
syntax errors on the first *blank* line of the source file.

I know this is a quite vague. I really don't know where to start to fix 
this or where to go for help. Please let me know what information I can 
provide that would be helpful.


More information about the Pythonmac-SIG mailing list