[Pythonmac-SIG] P4Python, MySQLdb, or Python Extensions

Lyndsey Ferguson lyndsey.ferguson at gmail.com
Tue Oct 9 17:59:41 CEST 2007

On 10/9/07, Nehemiah Dacres <vivacarlie at gmail.com> wrote:
> .so, if im not mistaken is eather a linux shared library or not a mac
> shared library (someone correct me if im wrong) try making sure the python
> version you chose is the one for mac. the best supported python for mac is
> macpython <http://www.python.org/download/releases/2.5.1/> (distributes in
> a mac installer package) from the python website but another more linux like
> one would be the darwinports one or the fink one. Try looking here
> <http://wiki.python.org/moin/MacPython/PythonDistributionsForMac>
> http://wiki.python.org/moin/MacPython/PythonDistributionsForMac

Thank you for the reply. I have removed older versions of Python and using
your link, installed Python 2.5 for the Macintosh.

After which I tried to build and install with the same problem. But I have
solved it and will post it to the author and this list (in case someone
follows in my footsteps).

In the setup.py for the Macintosh case, I had to add the
"extra_link_args=["-framework", "Carbon] to the setup call. This works and I
was able to run it in python.

Lyndsey Ferguson

Lyndsey Ferguson
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.python.org/pipermail/pythonmac-sig/attachments/20071009/59d9c8a0/attachment.htm 

More information about the Pythonmac-SIG mailing list