[Pythonmac-SIG] Trouble installing Tkinter with 2.3.5/10.2

Anthony Kozar mailing-lists-1001 at anthonykozar.net
Sun Jun 1 18:39:22 CEST 2008

Hello again,

I want to thank everyone for their responses on this issue -- I appreciate
the help!  I did get Python 2.3.7 with Tkinter to build on my 10.2 machine
and it was incredibly straightforward.  (I forgot to install WASTE, so the
IDE did not build, but that's OK for now).

More comments below, but that is the gist of this message :)

Anthony Kozar
mailing-lists-1001 AT anthonykozar DOT net

Ronald Oussoren wrote on 5/21/08 4:49 PM:

> On 21 May, 2008, at 5:00, Anthony Kozar wrote:
>> I would also just upgrade my 10.2 machine to a newer
>> Python but all of the 2.4 and 2.5 binary distributions appear to
>> require
>> 10.3.  Is this correct?
> That's correct, they require OSX 10.3.9 or later. There are two major
> reasons for that: first of all building universal binaries that
> support  OSX 10.2 is much more involved than limiting support to
> 10.3.9 and later, and furthermore I don't have hardware that's capable
> of running 10.2 and therefore could not even test such a build if I
> did create it.

You may not be able to test the 10.2 support, but a 10.2 build should run
fine on later OS versions.  But I understand that not having a test machine
is a good reason for not supporting older OSes :)

> You might have success in building a framework for OSX 10.2 from
> source. I don't think anyone has tried to do that for a while, but I
> see no reason why that shouldn't work (or could be made to work).

The 2.3.7 build I did is a framework.  I may try compiling 2.4 or 2.5 on
10.2 in the future unless I upgrade my OS before then (which now seems
>> So I am wondering what my options are now for cross-platform GUI
>> development with Python on 10.2?

> I'd drop support for 10.2.   OSX 10.2 is very ancient and Xcode
> doesn't even ship with an 10.2 SDK these days

Christopher Barker wrote on 5/21/08 2:33 PM:

> IIRC, Tk didn't work all that well back then, anyway, do you need to use
> Tk? (wxPython never worked on OS-9, though).
> This is an awful lot of work to support a pretty old OS though....

Kevin Walzer wrote on 5/21/08 1:42 PM:

> In this case, the platform you are supporting is considered by the
> community to be obsolete, and no effort is made to support it with
> current binary packages. Your only option, apparently, is to build from
> source.

I am sorry but not surprised I suppose that so many people feel that 10.2 is
"very ancient", "pretty old", or "obsolete".  I bought the computer running
10.2 only 5-1/2 years ago.  Sure it could run 10.5, but I long ago decided
that I did not want to play Apple's "upgrade game" anymore.  My Beige G3 can
only run up to 10.2 but it is more comfortable running OS 9.  These
computers satisfy most of my needs quite well.

I will point out that AFAICT, the Windows installers for Python 2.5 support
Windows 95.  The equivalent Mac OS version (timewise) would be System 7.5!
Just last year, I completed the Carbonization of a fairly large program.
The program now runs on MacOS 7, 8, 9, and 10.2 through at least 10.4 (I
assume 10.5 will work too -- the only reason it does not support 10.0 or
10.1 is because CoreMIDI is not functional in those versions).  This is
probably a specialized case, but it was not too difficult to maintain
support for System 7 in this program.

Before anyone gets upset by these comments, none of this is intended as a
criticism.  I am merely griping about the state of Mac development because I
have been rather frustrated the last couple of weeks trying to get several
open-source programs running on my 10.2 machine.

I do understand that the MacPython development team is probably much smaller
than the Windows team.  And the Mac OS and platform have undergone several
very significant changes during the last 13 years and Apple makes it much
more difficult to support older systems than Microsoft does.  In fact, I
think the blame lies with Apple due to the pace of their OS releases and
their attitude that anything older than 2-3 years is not worth supporting.
I am just continually saddened to see so many developers (especially for
open-source projects) who either adopt this attitude or are forced to
support only recent systems by the circumstances thrust upon them.

> Any reason you have to support 10.2, apart from the fact that it's what
> your machine runs? The user base for 10.2 is negligible.

I have been asked by a potential client to write a GUI for a cross-platform
program written in Python.  The request was to support "all platforms" that
the underlying program itself will run on.  That program has an interactive
commandline-like interface and is 100% pure Python, requiring only Python
2.3 to run.  It is distributed for Windows, Linux, Mac OS X, and even Mac OS
9.  The Python 2.3 minimum thus includes OS X 10.2 as a potential target for
the GUI.  I've already informed the client that OS 9 support is unlikely.  I
suppose that 10.2 support may be iffy if I have to upgrade to complete the
Maybe there are not many 10.2 users left.  But I still frequently hear from
people who are "just now" giving up their OS 9 machines for something newer.
It would be interesting to see some real numbers for how many 10.2 users
there are.

Sorry for the long "rant".  MacPython is a great piece of software and I
appreciated the help getting Tkinter working on 10.2.  Unfortunately, other
tools that I was hoping to use on this project (such as Guib, the successor
to SpecTcl) are proving to be much more difficult to install on 10.2 than
Tkinter was.

Thanks again!


More information about the Pythonmac-SIG mailing list