[Pythonmac-SIG] Can't build PIL on Snow Leopard

Ned Deily nad at acm.org
Mon Dec 7 09:50:19 CET 2009

In article <D1E85803-1222-4CDE-82DE-E004FA706850 at xiao-yu.com>,
 Xiao Yu <news at xiao-yu.com> wrote:
> There is no problem at all when I use Apple Python with pretty much 
> everything. Except when I have to distribute it with py2app. A separate 
> Python is essential for me. I could use MacPort or Fink but that would put me 
> a few versions behind the latest release. I'd really like to just use Python 
> from python.org and add all the libraries I need but I can't seem to compile 
> any libraries for this Python. They all end with a similar error. I'm not 
> sure what I'm missing. It gives the same error when I try to egg this too. 

For what it's worth, the MacPorts pythons seem to be keeping right 
up-to-date with the latest releases. 

   $ sudo port selfupdate
   $ sudo port install py26-pil py26-py2app-devel

should get you a working PIL 1.1.6, py2app 0.4.4, and python 2.6.4, all 
rooted in /opt/local/, e.g. /opt/local/bin/python2.6.

 Ned Deily,
 nad at acm.org

More information about the Pythonmac-SIG mailing list