[Pythonmac-SIG] [newbie] install PyObjc under EPD Python ?

Ronald Oussoren ronaldoussoren at mac.com
Tue Dec 22 09:51:46 CET 2009

On 21 Dec, 2009, at 18:34, Christopher Barker wrote:

> Ned Deily wrote:
>> Chances are, though, that their python2.5 does not allow you to correctly build packages with C extension modules (such as those in PyObjC) on 10.6.
> whooa!
> This appears to mean that python2.6 (or 3.1, I guess) is the only fully supported option for 10.6 and above?

2.6.4 contains a number of patches that make it possible to build extensions for the python.org binary installer on 10.6, those patches have been forward ported to the 3.1 tree, but there hasn't been a release of 3.1.x that includes those fixes. 2.7 and 3.2 will obviously also work when those are released.

Python 2.5 was released long before OSX 10.6 was released and there won't be any further maintainance releases, that's why the SL fixes haven't been backported to 2.5.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3567 bytes
Desc: not available
URL: <http://mail.python.org/pipermail/pythonmac-sig/attachments/20091222/cabcb733/attachment-0001.bin>

More information about the Pythonmac-SIG mailing list