[Pythonmac-SIG] py2app/PyQt/64-bit/Mach-O

Marc-Antoine Parent maparent at acm.org
Mon Dec 28 18:39:37 CET 2009

> It's just Tkinter--I have a four-way build (32/64 bit for PPC and Intel) of Tcl/Tk.

Hmmm.... I tried adding Tkinter to my "includes". Interestingly, the framework did not get added; apparently because it is a system framework.
I then tried adding it explicitly with the "frameworks" option of py2app; still not included.
I had an old 32bit build of Tcl/Tk frameworks in /Library, that one got added without issues.
I also tried moving the /System/Library/Frameworks/Tcl,Tk to /Library/Frameworks; that also worked without a hitch.
Can I ask you where you got your Tcl/Tk?
And more to the point, do you really need it, since it's been part of /System since 10.4?

That said, I have noticed another anomaly:
Sometimes, when I apply py2app twice, I get an error such as this one:

/usr/bin/strip: the __LINKEDIT segment does not cover the end of the file (can't be processed) in: /Users/maparent/OpenSource/leo-editor/dist/leo-editor.app/Contents/Frameworks/QtXmlPatterns.framework/Versions/4/QtXmlPatterns (for architecture x86_64)

The solution for me is to wipe the "dist" directory and start fresh. ("build" is not an issue.)
Would you mind trying that, just in case?


More information about the Pythonmac-SIG mailing list