[Pythonmac-SIG] Problems installing Python-2.7a3 on 10.6.2

Tom Loredo loredo at astro.cornell.edu
Mon Feb 22 04:40:52 CET 2010

Hi folks-

I've tried installing an intel framework universal build of
Py-2.7a3 on Snow Leopard 10.6.2 (i.e., i386 + x86_64).  I 
used this configure:

./configure --prefix=/usr/local/tmp --enable-framework --with-framework-name=PythonAlpha  --enable-universalsdk=/ --

"make" works fine, and "make test" appears acceptable (although
there is an error):

347 tests OK.
1 test failed:
33 tests skipped:
    test_al test_bsddb test_bsddb3 test_cd test_cl test_codecmaps_cn
    test_codecmaps_hk test_codecmaps_jp test_codecmaps_kr
    test_codecmaps_tw test_curses test_dl test_epoll test_gl
    test_imageop test_imgfile test_largefile test_linuxaudiodev
    test_ossaudiodev test_pep277 test_py3kwarn test_smtpnet
    test_socketserver test_startfile test_sunaudiodev test_timeout
    test_tk test_ttk_guionly test_urllib2net test_urllibnet
    test_winreg test_winsound test_zipfile64
1 skip unexpected on darwin:

"make install" works fine.  But the installed executable won't run.
I put /Library/Frameworks/PythonAlpha.framework/Versions/2.7/bin at
the front of my PATH.  Then:

$ which python
$ python
python: posix_spawn: python: Unknown error: 0

I also tried directly executing (with full paths) python, python2.7,
python2, and python-32 in the framework /bin/ directory, all with
the same posix_spawn error.  I also tried directly executing those
pythons in /usr/local/tmp, with the same result.

Any ideas what is preventing the installed versions from running
when the "make'd" version ran fine?  Are the non-standard paths
an issue?  I don't want to install into the usual /usr/local
paths, since I'm using homebrew to handle /usr/local.


This mail sent through IMP: http://horde.org/imp/

More information about the Pythonmac-SIG mailing list