[Pythonmac-SIG] py2app + wxpython -> ImportError

Christian K. ckkart at hoc.net
Mon Apr 11 22:29:38 CEST 2011


Am 11.04.11 21:11, schrieb Christian K.:
> Am 11.04.11 08:08, schrieb Ronald Oussoren:
>>
>> On 10 Apr, 2011, at 10:06, Christian K. wrote:
>
>>> File "wx/lib/pubsub/pub.pyc", line 24, in<module>
>>> File "wx/lib/pubsub/core/listener.pyc", line 13, in<module>
>>> ImportError: No module named listenerimpl
>>>
>>> I had (other) problems with pubsub using py2exe, too, and I needed to
>>> add
>>> 'wx.lib.pubsub' to the 'package' section of the setup options dict.
>>> That did
>>> not help py2app though.
>>>
>>> Any ideas?
>>
>> Adding "includes=['wx.lib.pubsub']" could help.
>
>
> Thanks, but that did not change anything.

I got one step further by adding

'includes':['wx.lib.pubsub.core.kwargs.*','wx.lib.pubsub.core.*']

then I unzipped site-packages.zip and copied the contents of
wx.lib.pubsub.core.kwargs to wx.lib.pubsub.core

and now I get:

File "wx/_gdi.pyc", line 3753, in GetTextExtent
wx._core.PyAssertionError: C++ assertion "Ok()" failed at 
/BUILD/wxPython-src-2.8.11.0/src/common/dcgraph.cpp(880) in 
DoGetTextExtent(): wxGCDC(cg)::DoGetTextExtent - invalid DC

Any ideas?

Christian



More information about the Pythonmac-SIG mailing list