[Pythonmac-SIG] Errors building Cython extensions on 10.9...

Ned Deily nad at acm.org
Tue Feb 11 02:28:17 CET 2014


In article 
<CALGmxELkm2vciF34LTPX67bahuvrdgU-hmH9siY=1G2LjcEOtQ at mail.gmail.com>,
 Chris Barker <chris.barker at noaa.gov> wrote:
> Have people in general been able to get extensions to build  right under
> 10.9? I"ve got a bunch of C++ code (and Cython-generated C++ wrappers),
> that hav been building fine on OS-X up to 10.8, and Windows, and LInux, but
> now I've got a user trying to build under 10.9, and they get a bunch of
> errors.
[...]
> Is there a way to get it to use the old lib, rather than changing our
> source and Cython, and ????

I've seen a lot of discussions on the MacPorts groups about the problems 
caused by the 10.9 change in the default C++ library.  It seems you can 
change it at compile time but you need to be careful that other C++ libs 
are also built the same.  See, for example:

http://stackoverflow.com/questions/19637164/c-linking-error-after-upgradi
ng-to-mac-os-x-10-9-xcode-5-0-1

-- 
 Ned Deily,
 nad at acm.org



More information about the Pythonmac-SIG mailing list