[PyVault-users] [Yum] Yum Version

Jeff Pitman symbiont at berlios.de
Wed Aug 31 05:46:40 CEST 2005

On Wednesday 31 August 2005 08:47, John Fox wrote:
> What yum version would be suitable for Centos 3?

I just built 2.3.4 for CentOS 3.5:


It requires a bit of a bootstrap to get working.  

Install python22-elementree, python22-urlgrabber with --nodeps at first.  
Also install sqlite from the same repo.

If you don't want to use PyVault at all and don't care for the python22 
names, download the appropriate SRPMS and rebuild on your system.

The bootstrap process is not well documented yet, so if you run into 
problems, let me know. (You can move the discussion over to 
pyvault-users, in this case.)

I'm working on the following in the meantime:

1. yum 2.4.x
2. A separate rpm-python package that operates from python2.4.  It will 
be named rpm-python24 and be installable in tandem with rpm-python 
(which resides in /usr/lib/python2.2/site-packages).

Then I'll probably get to documenting things better on the wiki.

have fun,

More information about the PyVault-users mailing list