[PyVault-users] fc3 yum Missing Dependency

Jeff Pitman symbiont at berlios.de
Sun Sep 4 18:47:21 CEST 2005

On Sunday 04 September 2005 21:48, TrabiGo wrote:
> --> Running transaction check
> --> Processing Dependency: python-optik for package: up2date
> --> Restarting Dependency Resolution with new changes.
> --> Populating transaction set with selected packages. Please wait.
> ---> Package python.i386 0:2.3.4-13.1 set to be updated

This is a bug in yum 2.2.x because it's not processing the Obsoletes 
correctly. For now, do this manually first:

$ yum install python24-optik

Then, things will work from now on.

I took Provides: python-optik out of python23, because I don't feel it's 
appropriately assigned especially in systems that have multiple 
python's installed.  I've also upgraded optik = 1.5 from their sf.net 
website; so it's upgrade path will now be directed through 

My current thinking is to get all distributions upgraded to yum 2.4.x to 
alleviate future problems in this regard. 


More information about the PyVault-users mailing list