[PyVault-users] Unable to satisfy dependencies -> python24-yum

Jeff Pitman jeff.pitman at gmail.com
Thu Jan 12 20:05:46 CET 2006


On 1/12/06, TrabiGo <trabigo at chello.at> wrote:
> Error: Unable to satisfy dependencies
> Error: Package python24-yum needs yum = 2.4.0, this is not available.
>
> of should I just download the rpm of 2.4.2 and make a force update ?
> thanks in advance for your help

Can you try "upgrade" or maybe the --obsoletes option? What's
happening is that pyvault has split the package into 2 sub-packages,
but you have an update to yum that combines them back into one. My
hope was that the depsolving would cause python24-yum to uninstall
given this scenario. But, it may look like it won't do it. Another
alternative is to see if smart can resolve this scenario.

To resolve by hand, you would need to remove yum && python24-yum, then
install the yum update.

--
-jeff


More information about the PyVault-users mailing list