Strange behaviour - Normalised Cut (on Macbook)

Vighnesh Birodkar vighneshbirodkar at gmail.com
Mon Nov 2 18:55:21 EST 2015


Hello

Can you tell us what numpy, scipy and arpack versions you are using ?

Thanks
Vighnesh

On Sunday, November 1, 2015 at 11:35:45 PM UTC-5, bricklemacho wrote:
>
> Here is some additional info,  the following gallery examples work as 
> expected:
>
> RAG Merging:  
> http://scikit-image.org/docs/dev/auto_examples/plot_rag_merge.html
> RAG Thresholding: 
> http://scikit-image.org/docs/dev/auto_examples/plot_rag_mean_color.html#example-plot-rag-mean-color-py
> Drawing Region Adjacency Graphs (RAGs): 
> http://scikit-image.org/docs/dev/auto_examples/plot_rag_draw.html#example-plot-rag-draw-py
>
> The last example the viridis wasn't available on 0.11.3 so just reused the 
> cmap in the example
>
> So it appears that only the Normalized Cut example that is exhibiting 
> strange behaviour, on my main machine.
>
>
> Michael.
> --
>
>
>  
> On 2/11/2015 12:02 pm, brickl... at gmail.com <javascript:> wrote:
>
> Hi All, 
>
> Running this example: 
> http://scikit-image.org/docs/dev/auto_examples/plot_ncut.html#example-plot-ncut-py
>
> On one machine, example works as expected.  On my work machine I am 
> getting the following results of normalised cuts example: 
> http://imgur.com/uWmvW2p 
>
> Details on machines and what I have tried is below. 
>
> Any help appreciated. 
>
> Regards, 
>
> Michael. 
> -- 
>
>
> Macbook 1 (work as expected): 
> -------------------------- 
> OS X Yosmite 10.10.4 
> Python 2.7.9 install via mac ports 
> skimage.__version__ 0.11.3 install via mac ports 
>
>
>
> Macbook 2 (strange behaviour) 
> -------------------------- 
> OS X Yosmite 10.10.5 
> Python 2.7.10 installed via mac ports 
> skimage.__verison__ 0.11.3 installed via mac ports 
>
> Things I have tried: 
> 1.  Reinstall from source via macports 
> sudo rm -rf 
> /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/skimage*
> sudo rm -rf 
> /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/scikit_image*
> sudo port upgrade -s -n --force py27-scikit-image 
> skimage.__version__: 0.11.3, identical result (http://imgur.com/uWmvW2p) 
>
> 2. Install latest development verison 
> sudo rm -rf 
> /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/skimage*
> sudo rm -rf 
> /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/scikit_image*
> git clone https://github.com/scikit-image/scikit-image.git 
> cd skikit-image 
> python setup.py build 
> sudo python setup.py install 
> skimage.__version__: 0.12dev, identical result: http://imgur.com/uWmvW2p 
>
>
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/scikit-image/attachments/20151102/8cfe9b03/attachment.html>


More information about the scikit-image mailing list