[scikit-image] Compilation Problems

Nathaniel Smith njs at pobox.com
Sun Jan 8 22:16:13 EST 2017

You appear to be using a self-built Python. Did you by chance forget
to install openssl-devel before building Python, so that you ended up
with a Python that has no ssl module?


On Sun, Jan 8, 2017 at 6:11 PM, James Board via scikit-image
<scikit-image at python.org> wrote:
> I'm on a Red-Hat-like Linux machine and I tried to install scikit several ways and failed.  Here was one attempt:
>> git clone https://github.com/scikit-image/scikit-image.git
>> cd scikit-image
>> python --version
> Python 2.7.9
>> pip install -e
> Traceback (most recent call last):
>   File "/usr/local/python/2.7.9/gnu//bin/pip", line 9, in <module>
>     load_entry_point('pip==8.1.0', 'console_scripts', 'pip')()
>   File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 568, in load_entry_point
>   File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 2720, in load_entry_point
>   File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 2380, in load
>   File "build/bdist.linux-x86_64/egg/pkg_resources/__init__.py", line 2386, in resolve
>   File "/usr/local/python/2.7.9/gnu/lib/python2.7/site-packages/pip-8.1.0-py2.7.egg/pip/__init__.py", line 15, in <module>
>     from pip.vcs import git, mercurial, subversion, bazaar  # noqa
>   File "/usr/local/python/2.7.9/gnu/lib/python2.7/site-packages/pip-8.1.0-py2.7.egg/pip/vcs/subversion.py", line 9, in <module>
>     from pip.index import Link
>   File "/usr/local/python/2.7.9/gnu/lib/python2.7/site-packages/pip-8.1.0-py2.7.egg/pip/index.py", line 30, in <module>
>     from pip.wheel import Wheel, wheel_ext
>   File "/usr/local/python/2.7.9/gnu/lib/python2.7/site-packages/pip-8.1.0-py2.7.egg/pip/wheel.py", line 39, in <module>
>     from pip._vendor.distlib.scripts import ScriptMaker
>   File "/usr/local/python/2.7.9/gnu/lib/python2.7/site-packages/pip-8.1.0-py2.7.egg/pip/_vendor/distlib/scripts.py", line 14, in <module>
>     from .compat import sysconfig, detect_encoding, ZipFile
>   File "/usr/local/python/2.7.9/gnu/lib/python2.7/site-packages/pip-8.1.0-py2.7.egg/pip/_vendor/distlib/compat.py", line 31, in <module>
>     from urllib2 import (Request, urlopen, URLError, HTTPError,
> ImportError: cannot import name HTTPSHandler
> Here's another attempt that failed:
>> easy_install --install-dir=/p/home/jpboard/SCIKIT -U scikit-image
> Creating /p/home/jpboard/SCIKIT/site.py
> Searching for scikit-image
> Reading https://pypi.python.org/simple/scikit-image/
> Download error on https://pypi.python.org/simple/scikit-image/: unknown url type: https -- Some packages may not be found!
> Couldn't find index page for 'scikit-image' (maybe misspelled?)
> Scanning index of all packages (this may take a while)
> Reading https://pypi.python.org/simple/
> Download error on https://pypi.python.org/simple/: unknown url type: https -- Some packages may not be found!
> No local packages or download links found for scikit-image
> error: Could not find suitable distribution for Requirement.parse('scikit-image')
> Can anyone tell what I'm doing wrong?   I tried all available options for me in the scikit documentation.  What should I do next?
> _______________________________________________
> scikit-image mailing list
> scikit-image at python.org
> https://mail.python.org/mailman/listinfo/scikit-image

Nathaniel J. Smith -- https://vorpus.org

More information about the scikit-image mailing list