[scikit-image] Compilation Problems

James Board jpboard2 at yahoo.com
Tue Jan 17 13:32:12 EST 2017


Making progress, but still no success.

I had my system admins re-install python with OpenSSL support.  Looks like it works.  I ran this command with no errors:

    >python -c "import ssl"

But I still run into problems installing scikit.  This was my install command

    > python setup.py install --prefix ~/SCIKIT

Here are the last few lines of error messages:

Processing dependencies for scikit-image==0.13.dev0
Searching for PyWavelets>=0.4.0
Reading https://pypi.python.org/simple/PyWavelets/
Download error on https://pypi.python.org/simple/PyWavelets/: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:581) -- Some packages may not be found!
Couldn't find index page for 'PyWavelets' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading https://pypi.python.org/simple/
Download error on https://pypi.python.org/simple/: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:581) -- Some packages may not be found!
No local packages or download links found for PyWavelets>=0.4.0
error: Could not find suitable distribution for Requirement.parse('PyWavelets>=0.4.0')

Does anyone know why this error occurs?



More information about the scikit-image mailing list