[scikit-learn] GridSearchCV not working properly

Mujeebur Rahman mujjub1997 at gmail.com
Fri Apr 16 08:36:52 EDT 2021

Dear Team,

I really like to work with sklearn tools. But I've been facing issues ever
since the latest version was released. It is about the GridSearchCV
function of model_selection.

With the previous version, I ran GradientBoostingClassifier with a set of
hyperparameters and fed it to GridSearchCV, setting verbose to 5. The train
data had around 800 rows and 100 columns. The model completed running
within 2-3 minutes.

With the latest version, I ran the same code without any changes. The only
change is with the number of rows, where around 200 rows have been added
extra. This time wheb I ran the code, it took nearly 20 minutes to
complete. And the verbose steps also didn't show up.

Please fix this issue as soon as possible. I really look forward to hearing
from you.

Thanks and Regards,
Mujeebur Rahman
Data Analyst
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.python.org/pipermail/scikit-learn/attachments/20210416/465b875f/attachment.html>

More information about the scikit-learn mailing list