[Shtoom] audio corruption and twisted required versions

Anthony Baxter anthony at interlink.com.au
Sun May 22 13:51:39 CEST 2005


I've spent a fair bit of time today on hunting down the audio corruption that 
occurred when shtoom refreshed it's registration. There's been a bunch of 
sanity added to the registration refresh, but I was still seeing very strange 
behaviour on some occasions. In frustration, I tried installing Twisted 2.0 
and making shtoom use that, and lo and behold, the problems went away. I'm 
wondering if there wasn't some strange bug with the gtk2reactor in Twisted 
1.3 (I was only able to get failures when using gtk2reactor). 

I'm strongly considering making Twisted 2.0 the minimum required version for 
shtoom, but would welcome comments. 

Anthony
-- 
Anthony Baxter     <anthony at interlink.com.au>
It's never too late to have a happy childhood.



More information about the Shtoom mailing list