[spambayes-bugs] [ spambayes-Bugs-802543 ] Outlook Plug-in does not filter mail moved by rules from inb

SourceForge.net noreply at sourceforge.net
Sun Oct 26 20:32:15 EST 2003

Bugs item #802543, was opened at 2003-09-09 01:23
Message generated for change (Comment added) made by mhammond
You can respond by visiting: 

Category: Outlook
Group: Outlook 001-007
Status: Open
Resolution: Works For Me
Priority: 5
Submitted By: bill cann (newsguy)
Assigned to: Mark Hammond (mhammond)
Summary: Outlook Plug-in does not filter mail moved by rules from inb

Initial Comment:
Outlook 10 is configured to move email from inbox to 
other folders based on email address of incoming mail. 
Spambayes outlook plug-in filters the mail that remains 
in inbox appropriately, but doesn't filter the mail that the 
rules move. (either in the inbox prior to the move, or in 
the destination folder after the move). All folders
inbox, and destination folders are specified for filtering. 
When rules to move mail are disabled, (leaving all mail in 
inbox), All mail is filtered appropriately.


>Comment By: Mark Hammond (mhammond)
Date: 2003-10-27 12:32

Logged In: YES 

I'd like to see some logs for people who still see this
problem.  Note that we know we have problems in this
scenario without Background mode enabled, so please make
sure you are using that before you attach the log.

Further, colforbin appears to have a different problem -
that the mail *is* filtered by SpamBayes but then ends up
back in the inbox!  Everyone else seems to have the problem
that SB simply isn't filtering these other folders.  Please
correct me if I am wrong.


Comment By: Joe Pinto (colforbin)
Date: 2003-09-27 03:28

Logged In: YES 

I am experiencing the same scenario, the filter correctly (and 
impressively!) identifies mail as spam, but the mail is not 
moved.  My environment is Outlook XP and Windows 2000 
professional.  I can see the e-mail 'visiting' the suspected and 
junk mail folders while watching the folder view in Outlook, 
but invariably they end up back in my inbox.  I have turned 
off my Rules, but it is still happening.  BTW, kudos for 
undertaking this effort, I will donate because this is such a 
great cause (and I encourage others to not take a 'free ride' 


Comment By: bill cann (newsguy)
Date: 2003-09-26 03:08

Logged In: YES 

I submitted the original report. At mhammond's suggestion, I 
installed .81 and after enabling the background mode, re-
establishing all the fields for spam scoring, and filtering the 
recipient folders as well as the inbox, The folders handled by 
Outlook rules were also automatically filtered as intended. 
When mail arrives, I can watch the mail initially being moved 
from the inbox to the separate folders by outlook rules, and 
then subsequently being moved from these folders to the 
Spam & Possible Spam folders by SpamBayes. 


Comment By: Oded Agam (odedagam)
Date: 2003-09-25 23:42

Logged In: YES 

Same thing happened to me as well.
But, I checked and saw that the plug in does not appear in 
the com add-in manager.  I've removed the spambayes 
software, deleted the spambayes folder under the application 
folder, deleted the spambayes toolbar from within Outlook 
and then installed the latest version 0081 of the plug-in.  
Then I configured the add-in again but all of this does not 
help.  I can use the spambayes toolbar and click "delete as 
spam" manually and it does the job right, but the automatic 
filtering of spam while I receive emails does not work at all.
If anyone has a resolution for this I would appreciate it.
I'm using Office xp professional and Outlook xp (2002) with sp-


Comment By: Jochen Tuchbreiter (whynot)
Date: 2003-09-15 09:49

Logged In: YES 

I can confirm this for 0081. I am moving all mail from my
inbox into 4 designated folders. Moving the mail detected as
spam/unsure never works for me. 

I have tried to select background processing. Including or
excluding Inbox in the list of filtered folders does not
help either.

Outlook XP (German version)


Comment By: Ken McIntosh (informsystems)
Date: 2003-09-12 09:08

Logged In: YES 

I just started using Version 0081 today and this problem is 
still occurring. (It was also occurring with the previous version 
I used, 007).

Like the other fellow, I use rules to move mail immediately 
from the Inbox to one of 6 different folders. In my case, each 
of those folders represents a different email account.

I've tried just filtering the Inbox, but the messages seem to 
get moved by the rules before SpamBaye filters them. I've 
also tried filtering just the 6 folders and not the Inbox and it 
seems to work sometimes but not other times. I have a 
feeling that I might workaround the problem by filtering my 6 
folders (not Inbox), while setting SpamBaye to "filter in the 
background", but I haven't done enough experimenting to see 
if this works for sure.


Comment By: Mark Hammond (mhammond)
Date: 2003-09-09 13:40

Logged In: YES 

What version?  If not version 008, can you please try it?


You can respond by visiting: 

More information about the Spambayes-bugs mailing list