[spambayes-bugs] [ spambayes-Bugs-797679 ] Recovered Mails filtered again

SourceForge.net noreply at sourceforge.net
Mon Sep 8 00:31:46 EDT 2003


Bugs item #797679, was opened at 2003-08-30 07:49
Message generated for change (Comment added) made by jaal2001
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=498103&aid=797679&group_id=61702

Category: Outlook
Group: None
Status: Open
Resolution: None
Priority: 5
Submitted By: Jan Albrecht (jaal2001)
Assigned to: Mark Hammond (mhammond)
Summary: Recovered Mails filtered again

Initial Comment:
Hi,



I don't know if this a bug or a design problem, so I 

posting it here.

When I recover a mail from Spam Folder in my opinion it 

should be marked as good on the database.

I have reapperaing mails, which we're marked as spam. 

But no matter how often I recover them from spam, the 

next mail from these events will be filtered again. 

Is this the normail behaviour or a known problem?



Thanks 



Jan

----------------------------------------------------------------------

>Comment By: Jan Albrecht (jaal2001)
Date: 2003-09-08 08:31

Message:
Logged In: YES 
user_id=855408

Hi,



here is the "clues" log from today morning.

Sorry for the XXX, but for security reasons I have to blank 

some things. But I've tried to change so little as possible.



Jan









Spam Score: 0.512408





word                                spamprob         #ham  #spam

'*H*'                               0.276798            -      -

'*S*'                               0.301613            -      -

'skip:a 10'                         0.180202          726     27

'ppp0'                              0.198911            4      0

'header:Message-Id:1'               0.22653           324     16

'inet'                              0.243728           21      1

'subject:New_Home_IP'               0.271305           18      1

'1,3d0'                             0.284601            2      0

'x-mailer:none'                     0.321254          932     75

'skip:e 20'                         0.369228           21      2

'reply-to:none'                     0.380298         1063    111

'to:2**0'                           0.625257          545    155

'header:Date:1'                     0.63781           583    175

'to:no real name:2**0'              0.643686          448    138

'header:From:1'                     0.648059          583    183

'protocol'                          0.749747            5      3

'to:addr:jan.albrecht'              0.86241           116    125

'header:Received:3'                 0.869959           77     89

'to:addr:XXX.de'            0.891541          116    164



Message Stream:





Received: from mx2.XXX.de ([XX.XX.XX.XX]) by mx2.XXX.de 

with

	SMTP (Microsoft Exchange Internet Mail Service 

Version XXX)

	id SPB4HM05; Mon, 8 Sep 2003 04:59:55 +0200

Received: from XXX.XXX.XX.XXX by mx2.XXX.de (InterScan E-

Mail

	VirusWall NT); Mon, 08 Sep 2003 04:59:55 +0200

Received: (from root at localhost)

	by tower.center.bluecove (8.11.2/8.11.2/SuSE Linux 

8.11.1-0.5) id

	h88303h17065

	for jan.albrecht at XXX.de; Mon, 8 Sep 2003 05:00:04 

+0200

Date: Mon, 8 Sep 2003 05:00:04 +0200

From: root <root at tower.center.bluecove>

Message-Id: 

<200309080300.h88303h17065 at tower.center.bluecove>

To: jan.albrecht at XXX.de

Subject: New_Home_IP





1,3d0

< ppp0      Link encap:Point-to-Point Protocol  

<           inet addr:XXX.XXX.XX.XXX  P-t-P:XXX.X.XX.XX  

Mask:255.255.255.255

< 



Message Tokens:



29 unique tokens



'1,3d0'

'cc:none'

'content-type:text/plain'

'from:addr:root'

'from:addr:tower.center.bluecove'

'from:name:root'

'header:Date:1'

'header:From:1'

'header:Message-Id:1'

'header:Received:3'

'header:Subject:1'

'header:To:1'

'inet'

'link'

'message-id:@tower.center.bluecove'

'ppp0'

'protocol'

'reply-to:none'

'sender:none'

'skip:a 10'

'skip:e 20'

'skip:m 20'

'skip:p 10'

'subject:New_Home_IP'

'to:2**0'

'to:addr:XXX.de'

'to:addr:jan.albrecht'

'to:no real name:2**0'

'x-mailer:none'



----------------------------------------------------------------------

Comment By: Mark Hammond (mhammond)
Date: 2003-09-08 06:52

Message:
Logged In: YES 
user_id=14198

Can you please attach the "clues" for one of these messages?

----------------------------------------------------------------------

Comment By: Jan Albrecht (jaal2001)
Date: 2003-09-05 07:27

Message:
Logged In: YES 
user_id=855408

Hi,



no, it's not exactly the same mail.

The Mail contains the follwoing entries:



2c2

<           inet addr:XXX.XXX.XXX.XXX  P-t-

P:XXX.XXX.XXX.XXX  Mask:YYY.YYY.YYY.YYYY

---

>           inet addr:MMM.MMM.MMM.MMM  P-t-

P:MMM.MMM.MMM.MMM  Mask:NNN.NNN.NNN.NNN



The X and M differs from mail to mail, as the're dynamic IP's. 

The other parts of the mail are the same.



When I do a "recover from spam" with this mail, the score 

does not shift ti zero. The score goes back from 60% to 59%.



The log is attached. Let me know, if you need more 

information.



----------------------------------------------------------------------

Comment By: Mark Hammond (mhammond)
Date: 2003-09-01 10:46

Message:
Logged In: YES 
user_id=14198

Are you trying to repeatedly train the exact same mail, or a

new, similar one?  You can't train the same message multiple

times.



Each time you train, you should notice the "spam score"

shift back towards zero.  It may not shift enough to have it

considered good, but it should shift.  It is does, then it

will eventually learn.  If it doesn't, then we have a bug -

but I will need the log file from a session where you have

tried to perform this training.  If you do submit the log

file, please reset the bug status to "open"

----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=498103&aid=797679&group_id=61702



More information about the Spambayes-bugs mailing list