[spambayes-dev] Re: unicode error in sb_dbexpimp.py

Tony Meyer tameyer at ihug.co.nz
Tue Mar 9 19:50:19 EST 2004


> A better solution, IMO, would be to use the csv module.  I
> have a patch ready to check in.  Unfortunately that would 
> restrict sb_dbexpimp.py to Python 2.3 or greater.  Feedback?

I meant to also say that I, too, sometimes use SpamBayes with 2.2 and can't
move to 2.3 (it's on our cluster here), but only the testtools, so it
wouldn't actually effect me in practice to have this one script not work.

OTOH, when 1.0a7 (I think it was that one) was released with some scripts
that were missing the 2.2 compat code, there were a few people that mailed
the list about it, so there must be at least a few others.  I'd have no idea
about how many actually use db_expimp.py, though.

=Tony Meyer




More information about the spambayes-dev mailing list