[spambayes-dev] Baffling new Outlook SB dialog problem

Tim Peters tim.peters at gmail.com
Tue Jun 21 01:59:27 CEST 2005

>>> Wondering whether anyone else has seen this:  I noticed
>>> today that the file-choosers in my OL 2003 SB "just stopped working".
>> They're broken here (OL 2002), too.  No idea since when
>> (can't even remember the last time I used those controls).  I
>> suspect that means that either Kenny or I broke them at some point.

> Or maybe *Mark* broke them :)  The code is calling the
> [win32gui.SendMessage] function (to insert the items into the list) fine,
> so I went back to an old pywin32 (201, picked somewhat at random) and it
> works fine.

Bingo!  I installed build 204 several weeks ago, to worm around
problems with Zope software picking up a "too old" version of pywin32,
and because I like Mark <wink>.  If you don't tell him, I'll admit I
was using build 163 before.  Reinstalling that fixed my baffling SB
problems.  I misremembered the time sequence here, because I know I
used the folder selectors since then -- but now that I know what I'm
looking for, I remember that was on a different machine (w/o build

Interesting:  since I had deleted my SB config and couldn't use the
folder controls to select folders again, SB was dead in the water.  I
turned on OL2003's native spam filtering again, then did the Office
Update bit to update its database after just two hours of retrieving
work messages from its "Junk E-Mail" folder.  Updating the database
didn't seem to help.  I'm delighted to have SB back!  You guys must be
genuises, at least <wink>.

try-living-w/o-it-for-a-day-ly y'rs  - tim

More information about the spambayes-dev mailing list