[spambayes-dev] Big old checkin - Hello Python 2.4, Goodbye Python 2.[23]

skip at pobox.com skip at pobox.com
Tue Jan 27 12:32:00 CET 2009


If you have a chance (even just a few minutes) and are comfortable with
running or at least testing SpamBayes from Subversion it would help if you
could svn up and try the current state of affairs.  You *will* need Python
2.4 or later.  I run routinely with Python 2.7a0.

I just ripped out all code which attempted to support Python 2.2 and 2.3.
All sorts of stuff was previously not assumed to exist:

    textwrap, cStringIO, __file__, True/False, set, heapq, csv, enumerate,
    reversed

Those are all assumed to just be there now.

Support for Berkeley DB v1.85 databases is completely gone.  If you were
still using it you'll have to choose something else and retrain from
scratch.

Finally, and perhaps most significant, I checked in a new file at the top
level, failing-unit-tests.txt.  It's the output of me running

    BAYESCUSTOMIZE= nosetests --verbose . 2>&1 | tee failing-sb-tests.txt

THere is lots of work to do to get this stuff passing.  Lots of file cleanup
as well, but that's secondary.  If you an see how to make any failing tests
pass that would be a huge boon.  Of course, adding new test cases is always
welcome.

Skip


More information about the spambayes-dev mailing list