[Spambayes] Spambayes Header Format

Rob Hooft rob@hooft.net
Sun Nov 3 12:18:11 2002

Richie Hindle wrote:
> Hi Rob,
>>Lots of discussion about the Spambayes header, but nobody takes any 
>>concrete initiatives. For me, the proposal...
>>    X-Spambayes-Classification: {Ham|Unsure|Spam}
>>...looks very good. But obviously this will break backward 
>>compatibility.  And since I'm only using hammie.py and procmail, I can 
>>only change those parts and test them. To make everything work together 
>>again we'd have to make a concerted effort. Better now than later?
> I agree.  I volunteer to make the edit, and to combine any duplicated code
> ("if prob > spam_cutoff: disp = 'Yes'" currently appears in at least two
> places, for instance).

Other todo items and ideas:
  - Make the "Yes, Unsure, No" items into Options, keeping the defaults
    the same as in the past for a few days.
  - Add the debugging info optionally as X-Spambayes-Info


Rob W.W. Hooft  ||  rob@hooft.net  ||  http://www.hooft.net/people/rob/