[Spambayes] New bsddb3 for Python 2.2

Mark Hammond mhammond at skippinet.com.au
Tue Mar 11 08:43:12 EST 2003


There have been some reports of problems running the spambayes Outlook
plugin on Python 2.2 with bsddb3.

It turns out that the bsddb3 release itself was bad.  The bsddb3 maintainers
have released a new version of the binary (from the usual place -
http://sourceforge.net/project/showfiles.php?group_id=13900).

If you install this version of bsddb3, spambayes should work fine (and
fast!).  This bsddb module is also built using the same database version as
the Python 2.3 bsddb module, so our database can be freely used between
stock Python 2.3, and Python 2.2+bsddb3.

Remember that there is no pickle->db migration code in Outlook - you are
probably going to need to do a full re-train if you install bsddb3.  If the
startup/shutdown times are annoying you, it is well worth it though.

Mark.




More information about the Spambayes mailing list