[Spambayes] Imap Filter Setup Error

Tony Meyer tameyer at ihug.co.nz
Tue Feb 3 17:08:40 EST 2004


> I am now trying to get the imap filter working, but am
> running into issues with configuration. I downloaded the
> imap filter:  spambayes-1.0a7.zip. 
[...]
> when I click on 'configure folders to filter' or
> 'configure folders to train' it gives the following error: 
[...]
> ExpatError: not well-formed (invalid token): line 1, column 31 

This is a known bug with the 1.0a7 and is fixed in the next release.  The
problem is that one or more folders on your server have a <, >, or & in
them, and they aren't properly handled before displaying the web interface.

For the moment, the solution is to manually configure the folders that you
want to configure.  IOW, open up your bayescustomize.ini file and add the
appropriate options (all in the [imap] section).  The FAQ explains how to
get information about what options to set and what values are appropriate.

In addition, keep track of the announce list, and upgrade to the new version
of spambayes/imapfilter when it is released - this includes both the fix for
this and many other imapfilter improvements (the release includes details
about what has changed).

=Tony Meyer

---
Please always include the list (spambayes at python.org) in your replies
(reply-all), and please don't send me personal mail about SpamBayes. This
way, you get everyone's help, and avoid a lack of replies when I'm busy.




More information about the Spambayes mailing list